Life has its own fate, and meeting may not be accidental.

0%

pta-7-21 红色警报 (25分)(并查集)

7-21 红色警报 (25分)

题目

战争中保持各个城市间的连通性非常重要。本题要求你编写一个报警程序,当失去一个城市导致国家被分裂为多个无法连通的区域时,就发出红色警报。注意:若该国本来就不完全连通,是分裂的k个区域,而失去一个城市并不改变其他城市之间的连通性,则不要发出警报。

输入格式

输入在第一行给出两个整数N(0 < N ≤ 500)和M(≤ 5000),分别为城市个数(于是默认城市从0到N-1编号)和连接两城市的通路条数。随后M行,每行给出一条通路所连接的两个城市的编号,其间以1个空格分隔。在城市信息之后给出被攻占的信息,即一个正整数K和随后的K个被攻占的城市的编号。

注意:输入保证给出的被攻占的城市编号都是合法的且无重复,但并不保证给出的通路没有重复。

输出格式

对每个被攻占的城市,如果它会改变整个国家的连通性,则输出Red Alert: City k is lost!,其中k是该城市的编号;否则只输出City k is lost.即可。如果该国失去了最后一个城市,则增加一行输出Game Over.

输入样例:

1
2
3
4
5
6
7
5 4
0 1
1 3
3 0
0 4
5
1 2 0 4 3

输出样例:

1
2
3
4
5
6
City 1 is lost.
City 2 is lost.
Red Alert: City 0 is lost!
City 4 is lost.
City 3 is lost.
Game Over.

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
#include<bits/stdc++.h>
using namespace std;
int f[6000];
int vis[10000]={0};
struct fun{
int x,y;
}great[10000];
int find(int x){
if(x!=f[x]){
return find(f[x]);
}
return x;
}
void marge(int x,int y){
int fx=find(x);
int fy=find(y);
if(fx!=fy){
f[fy]=fx;
}
}
void init(){
for(int i=0;i<6000;i++){
f[i]=i;
}
}
int main(){
init();
int n,m,a,b;
scanf("%d %d",&n,&m);
for(int i=0;i<m;i++){
scanf("%d %d",&a,&b);
great[i].x=a;
great[i].y=b;
marge(a,b);
}
int num=0;
for(int i=0;i<n;i++){
if(f[i]==i){
num++;
}
}
int t;
scanf("%d",&t);
for(int i=0;i<t;i++){
scanf("%d",&a);
init();
vis[a]=1;
int num1=0;
for(int i=0;i<m;i++){
if(vis[great[i].x]!=1&&vis[great[i].y]!=1){
marge(great[i].x,great[i].y);
}
}
for(int i=0;i<n;i++){
if(f[i]==i){
num1++;
}
}
if(num1==num||num1==num+1){
printf("City %d is lost.\n",a);
}
else{
printf("Red Alert: City %d is lost!\n",a);
}
num=num1;
}
if(t==n){
printf("Game Over.\n");
}
return 0;
}